Keyboard shortcuts

Press ← or → to navigate between chapters

Press S or / to search in the book

Press ? to show this help

Press Esc to hide this help

RFC 9097 §4: General Parameters and Definitions

The 9 Requirements of RFC 9097 §4, each quoted from the RFC with its state and the tests that prove it. Conformance explains the states.

StateRequirements
Tested7
Not applicable2

RFC9097-4-1

Not applicable

This section lists the REQUIRED input factors to specify a Sender or Receiver metric.

Note: An introduction to the section’s Requirements, each recorded with its own ID; nothing to do beyond them.

RFC9097-4-L1

Tested

The nominal duration of a measurement interval at the Destination (default 10 sec).

Note: I, the Test Interval (testIntTime).

Proving tests:

RFC9097-4-L2

Tested

The nominal duration of m equal sub-intervals in I at the Destination (default 1 sec).

Note: dt, the Sub-Interval (subIntPeriod).

Proving tests:

RFC9097-4-L3

Tested

The results are evaluated throughout the test to determine how to adjust the current offered load rate at the Sender (default 50 msec).

Note: FT, the Trial Interval (trialInt).

Proving tests:

RFC9097-4-L4

Tested

A maximum waiting time for test packets to arrive at the Destination, set sufficiently long to disambiguate packets with long delays from packets that are discarded (lost), such that the distribution of one-way delay is not truncated.

Note: Tmax.

Conformance Records: tmax-within-the-sub-interval.

Proving tests:

RFC9097-4-L5

Tested

The number of different flows synthesized by the method (default one flow).

Note: F; more than one is a Multi-Connection Test.

Proving tests:

RFC9097-4-2

Not applicable

Note: The IPv6 flow label SHOULD be included in the flow definition when routers have complied with the guidelines provided in [RFC6438].

Note: About the flow definition: udpstp sets no IPv6 flow label, and the OS’s is constant for a socket, so a Test Connection is one flow with or without it.

RFC9097-4-3

Tested

If there is payload compression in the path and tests intend to characterize a possible advantage due to compression, then payload content SHOULD be supplied by a pseudorandom sequence generator, by using part of a compressed file, or by other means.

Note: Random payload (CHTA_RAND_PAYLOAD, --random-payload).

Proving tests:

RFC9097-4-4

Tested

At least one fundamental metric and target performance threshold MUST be supplied (such as one-way IP packet loss [RFC7680] equal to zero).

Note: PM: the Performance Criterion.

Proving tests: